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Using this PDF tutorial requires only a 
basic knowledge of how computer 
programs work. The user must be 
familiar with the use of a mouse and how 
it works in other computer programs.  
How to use a computer-aided design, 
CAD, program is NOT required.


The only unfamiliar term is “coordinates”, 
but how the term is used is explained 
during the tutorial.


This tutorial PDF document was written 
on a Mac, therefore, the screen captures 
look slightly different than on a Windows 
operating system computer.


It is very highly recommended that the 
user reads through the Problems and 
Workarounds section.  LEFT-Click this 
bookmark link to go there.  There is a 
return bookmark link, at the end of the 
section, to return here.


Open xtrkcad. Select File>New to follow 
along with the tutorial.


Concepts Page (No return link to the 
“Beginner Tutorial” - Return in sidebar)


http://xtrkcad-fork.sourceforge.net/
Wikka/Concepts


Layout: (Revision and notes)

Usually, the Layout in XtrkCAD is the 
whole surface area of the floor, or 
ground, over which tracks are placed in a 

given area such as a room, or rooms, or 
an outdoor area. It can be re-sized at any 
time (Options>Layout). 

It is rectangular. For a non rectangular 
space, the “Room Width and Height” can 
be made large enough for the longest 
and widest part of the overall area and a 
background image, or drawing elements, 
can be used to show the actual 
boundaries of the track layout.

The terms “widest/width” and “tallest/

height” can be confusing in American 
English.

Room Width, as used in this program, 
means the longest linear dimension of 
the overall area, in inches, where the 
layout will be installed and Height means 
the other dimension, or widest overall 
linear dimension, in inches, going 
“across” that surface.


Note: For the tutorial, a 4’ x 8’ flat 
surface is created to demonstrate some 
techniques for creating a layout.  To keep 
it simple, the room size area, where the 
4’ by 8’ “Layout” is to be placed, is not 
demonstrated.


Tracks

Note: Only sectional track is used in the 
tutorial.


Draw Objects

Note: There are no draw objects in the 
tutorial.
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Turnouts: Revision


Turnouts are collections of tracks (and 
possibly draw objects). They have the 
unique ability to have a dynamic property 
when used in Train Mode, when a train is 
being run on the partially completed, or 
completed, layout. The turnout can be 
“switched”, when the SHIFT key is held 
down, the cursor is over the turnout 
and a LEFT-Click mouse button is 
commanded, if there are alternative 
paths that go from one end-point to 
more than one other end-point. Turnouts 
can be created by grouping tracks and 
draw objects.


Structures 
Note: There are no drawn structures in 
the tutorial.


Notes 
Note: There are no notes created in the 
tutorial.


Cornus 
Note: There are no cornu curves created 
in the tutorial.


Control Objects 
Note: There are no control objects 
created in the tutorial.


Layers 
Note: There are no layers created in the 
tutorial.


Command Concepts 

Hot Bar (noted across top of page) 

The Hot Bar contains elements that can 
be selected and placed onto the layout. 


Its contents are set using the 


File>Parameter Files…

The only parameters shown are the ones 
that are in the currently selected Scale 
and Gauge (Options>Layout).

The same list is presented in 
Add>Predefined Track and 
Add>Structure menus. 


Parameter files can be unloaded to hide 
them. 




A mouse RIGHT-Click on the Hot Bar 
opens a pop-up menu that allows the 
user to jump to various sections of 
the Hot Bar. (Shown on previous page)


To select an object, LEFT-click on the 
desired object in the Hot Bar to highlight 
it, which selects it. Move the cursor to 
the layout drawing area and LEFT-click. 
(Do NOT try to drag the object onto 
the drawing area!)  

The object is placed on the layout at the 
cursor’s position and shown only as a 
group of lines in a color that is not black. 
As long as the object remains not black, 
or anchored, it can be dragged by the 
mouse to move it into a desired position 
or the cursor can be moved to specific X 
Y coordinates and the mouse LEFT-
Clicked at those coordinates. After the 
mouse click, the object moves/jumps to 
the cursor’s coordinates.

The orientation of a Turnout, or curved 
sectional track, can be changed via 
Shift+LEFT-Click. Once it is in the 
proper position, the SPACE Key or 
ENTER Key is pressed to anchor the 
object to the drawing area.


Joining 

Track ends can be next to each other 
and not joined in XtrkCAD, just like real 
track without fishplates. 


In Train mode, unjoined track joints 
cannot be traversed. 


The Join AND Connect commands act to 
stick the track together when the 
Magnetic Snap is on. View>Magnetic 
Snap in the main menu bar is enabled. 

Connect two tracks only works when 
the two tracks are very close to each 
other and aligned enough (equal angles). 


Join two tracks tries to add a piece of 
flexible track to fill in a gap (large or 
small). It will attempt to use an easement 
(a piece of track that slowly moves from 
one radius to another, avoiding a quick 
jerk) if the Easement setting is NOT 
“None".  Note that the default setting for 
Easement is None; used in the tutorial.


Elevations 
There are no elevations created in the 
tutorial.


Inventory 
The inventory is created automatically 
during the tutorial.


Train Mode 
Train mode is used in this tutorial and 
explained later.


Introduction to the User Interface 
http://xtrkcad-fork.sourceforge.net/

Wikka/FirstSteps

Now, use the link to read the information 
on that page.


Starting a plan 
http://xtrkcad-fork.sourceforge.net/

Wikka/FirstLayout


Setting up size and scale 

If this is NOT the first time the program 

has been run, choose File>New… to 

start a new layout plan.


To start a new track plan, enter the length 
and width dimensions of the area where 
the layout is planned to go. Select the 
scale and gauge of the track to be used. 
If the Layout window, named Layout 
Options, is not open, it can be done via 
the layout options at Options>Layout. 
The command opens the following dialog 
box.


http://xtrkcad-fork.sourceforge.net/Wikka/FirstSteps
http://xtrkcad-fork.sourceforge.net/Wikka/FirstSteps
http://xtrkcad-fork.sourceforge.net/Wikka/FirstLayout
http://xtrkcad-fork.sourceforge.net/Wikka/FirstLayout


For this tutorial, set the layout size to a 
Room Width of 96" and a Height of 48". 
Enter a name for the Layout Title. 

Set the Scale to "HO (1/87.1)" and the 
Gauge to "Standard (16.5mm)".


To modify the units to metric, adapt the 
parameter in 

Options>Preferences>Units : Metric.


Finish the basic configuration by a LEFT-
Click on the Ok button.


Using File>Save, create a name for the 
layout file and save it.


Selecting Track 

XTrackCAD has libraries 
of many different brands 
of track available. For this 
tutorial use Atlas Code 
100 Track.


Navigate 
to File>Parameter Files

Select as many files as 
desired, but, to make 
things easier, it is best to 
unload all the parameter 
files that are not going to 

be used. Unload the files by selecting the 
file and clicking on the "Unload" button.


If no parameter files are listed in the 
window (and there won’t be the first time 
the program is run), click the “Browse…” 
button and choose one or more 
parameter files to load. If the program 
was previously run for a HO layout, 
LEFT-Click the Library… button to 
select the brand(s) to use.


Important remark: The parameter file 
ONLY loads the libraries ACCORDING to 
the scale and gauge chosen in 
Options>Layout.


When the program starts for the 
first time, it is configured in N 
scale. It will NOT show HO tracks 
until the scale is set to HO and 
gauge to Standard.


For this tutorial, make sure that the 
“Atlas Code 100 HO Scale” 
parameter file is loaded. Also load 
the “North American Rolling Stock 
Prototype Cars”, as it is used later. 
The loaded files can be seen in the 
screen capture.


There is a descriptive list of the 
parameter file names available on the 



[ParameterFiles] page. 

http://xtrkcad-fork.sourceforge.net/Wikka/ParameterFiles


If no files can be seen, make sure the file 
chooser is pointing at one of the 
following directories, depending on your 
operating system:

Mac OS X : /Applications/
XTrackCAD.app/Contents/Resources/
share/xtrkcad/params

Linux: /usr/lib/xtrkcad/params

Debian Linux: /usr/share/xtrkcad/params

Windows: (???)


Placing the first track piece 

Once the Parameter files are selected, 
the Hot Bar shows a long row of Atlas 
track. 


Use the Scroll Arrows, at each end of 
the Hot Bar, to move to the left or right 
until the fixed length pieces can be seen. 


For the first piece, LEFT-Click in the Hot 
Bar to highlight an "Atlas #821, 9" 
Straight”, which selects it.


To place it in the drawing area, LEFT-
Click anywhere onto the drawing area. 


The two “rails” of the 9” track piece 
appear as lines in a color other than 
black. As long as the lines are in color, 
the track can moved around by a LEFT-
Click on any position on the layout area.


To coincide with the steps of this tutorial, 
the track section should anchor itself to 
the right side of the cursor. If it's not, and 
you won’t know that until a try is made to 
move it to a specific location, hold down 
the SHIFT key and then RIGHT-Click to 
open the rotation menu. 


Select 180°. The track rotates 180° and 
anchors the cursor to the opposite end 
of the track. 


Leave the straight piece, in color, where it 
is. Move the cursor pointer to the x-
position 24" and y-position 46” towards 
the upper left of the drawing area.  


(Note that the X and Y coordinates are 
located at the bottom, left of the screen.)
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Once the cursor is positioned at the x-
position 24" and y-position 46”, LEFT-
Click the mouse and the track “jumps” 
to that position.


IMPORTANT: If the 9” straight track is 
between 1’ and ends at the 2’ mark, it 
has to be rotated, as previously noted.  

The correct position is when the 9” 
straight track starts at 2’ and extends to 
the right towards the 3’ mark.


In order to anchor the track piece in 
place, press the SPACE or ENTER key. 


The color of the piece changes, the 
endpoints are drawn, and the layout 
looks like the screen capture above.


Getting around a curve


Set up the first curve. LEFT-Click to 
highlight an "Atlas #836, 22" 22.5D 
Curve”, which selects it. 


Move the cursor close to the left end of 
the 9” straight track. Once the cursor is 
at the left end of the 9“ straight track, 
LEFT-Click the mouse. The track snaps 
into place.


If the curve is going the “wrong” way, 
with the cursor near the curve, press 
and hold the SHIFT Key and then LEFT-
Click while the track is still colored. The 
curved track jumps to the other direction. 


Once the position is correct, press the 
SPACE or ENTER Key. 




The track plan should look like this.


Complete the half circle. Left-Click onto 
the unconnected end of the curve and 
the next 22” curved piece appears. 


Press the SPACE or ENTER key to 
anchor the track section. 


Move the cursor to the open end of the 
just anchored piece and LEFT-Click.


Press the SPACE or ENTER key to 
anchor the track section.


Repeat until the curve reaches 180 
degrees, as shown below.


Should the new piece not snap into 
place, drag it (hold the left mouse button 
down while moving the mouse pointer) 

closer to the unconnected end before 
pressing the SPACE or ENTER key.


Now is a good time to do a Save. 

From Loop to Oval 
http://xtrkcad-fork.sourceforge.net/

Wikka/LoopOval


The following instructions are a guide 
through the selection and placement of 
the sectional track pieces required to 
transform the loop of track, created in 
the previous exercise, into an oval layout. 


Work on the loop starts in the upper left 
quadrant and progresses, in a clockwise 
manner, around the layout until an oval 
layout exists.


Extend Mainline 
The first step is the extension of the 
mainline track from the top of the loop to 
the right side of layout. This is achieved 
through selection and placement of four 
pieces of Atlas 9" sectional track.


LEFT-Click in the Hot Bar to highlight, 
an "Atlas #821, 9” Straight, which selects 
it.


Move the cursor into the drawing area so 
that it aligns with the right end of the 
previously positioned 9” straight track. 


Once the cursor is in position, LEFT-
Click and then press the SPACE or 
ENTER key to anchor the track into 
position.


Use the same method as used for 
completing the half circle to complete the 
mainline by placing three additional 
sections of "Atlas #821, 9" Straight" 
track next to the piece that was just laid.
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When finished, the track plan looks like 
the following screen capture.


Looping Back 
A curved section of track is constructed 
from the end point of the straight section 
back toward the point of origin of the first 
loop. This is achieved through the 
addition of five sections of 18”, 30D 
curved track.


LEFT-Click in the Hot Bar to highlight an 
"Atlas #833, 18” 30D Curved" track, 
which selects it. 



Move the cursor and place it adjacent to 
the right end of the last placed 9” straight 
track. LEFT-Click the mouse button and 
the track should snap into place at the 
end of the straight track. 


If the track curves the wrong way, press 
and hold the SHIFT key down and 
LEFT-Click on the curved section of 
track.


Once the curved section of track is 
reoriented, press the SPACE or ENTER 
Key to anchor the track into position.


Continue building the loop by adding 
four additional sections of "Atlas #833, 
18” 30D Curved" track. Don't be 
concerned about the loop not extending 
to 180 degrees. Additional track sections 
are added during the next step.


The Alignment Process Begins 
The loop of track, on the left side of this 
layout, was constructed using "Atlas 836 
22" 22.5D Curved" track. In order to join 



the loop being created in this exercise, 
with the loop on the left side of the 
layout, it is necessary to bring the 
unconnected sections of track into 
alignment. This is achieved through the 
placement of three short pieces of 18” 
10D curved track, but NOT ALL THREE 
ATTACH TO EACH OTHER.


LEFT-Click in the Hot Bar to highlight an 
"Atlas #835, 18” 10D Curved”, which 
selects it.


Move the cursor to the open end of the 
18" curved track and Left-Click to place 
the curve. If the track section curves the 
wrong way, hold down the SHIFT key, 
LEFT-click on that track section. 


Once the track is oriented correctly, 
press the SPACE or ENTER key to 
anchor the track in position. 


Add a second piece of 18” 10D track to 
complete this step of the exercise.


Heading Home! 
LEFT-Click on the Hot Bar to highlight 
an "Atlas #821, 9” Straight”, which 
selects it. 


Move the cursor next to the open end of 
the last "Atlas #835, 18” 10D Curved” 
and Left-Click to place it.


Once the track is in position, press the 
SPACE or ENTER key to anchor the 
track in position.


Complete this section of mainline track 
by placing four additional sections of 
"Atlas #821, 9" Straight" track next to the 
18” 10D that was just laid.


The Alignment Process Ends 
The alignment process started with the 
placement of two 18” 10D curved tracks 
at the bottom of the right hand loop. 


In this step, the third section of 18” 10D 
track is added to complete the alignment 
process.




LEFT-Click in the Hot Bar to highlight an 
"Atlas #835, 18" 10D Curved”, which 
selects it.

Move the cursor to the open end of the 
last 9” section. Left-Click the mouse to 
place the track.


Once the track is positioned, press the 
SPACE or ENTER key to anchor it into 
position. 


If the default setting for "Connection 
Distance" has not been changed, then 
the last section of track may not 
connect to the 22" curved section of 
track to its left. 


If this happens, follow the instruction in 
the next section; “Making Things 
Connect".


Making Things Connect 
If the left side of the 18" 10D Curved" 
track didn't connect to the right side of 
the existing 22" curved section of track 
don't worry. Sectional track has enough 
"play" to overcome the slight space that 
remains between the two tracks and can 
be pulled together for a final connection.


To achieve the same affect with XTrkCad, 
a slight change to the "Connection 
Distance" parameter is required. 


Open the Preferences window by using 
the Options>Preferences… menu.


In the field titled "Connection Distance", 
change the default entry from 0.100 to 
read 0.150 (.38 MM) then LEFT-Click the 
Ok button to save the change.


Connect the two tracks using 
“Change>Connect Two Tracks", the 
“Connect two tracks” button or the 
<Ctrl+Shift+J> command. 

Note that this is the Connect command.  
It is NOT the Join command!


Note that the message in the status bar 
asks the user to "Select first End-Point to 
connect." LEFT-Click on the 
unconnected end of 22" 22.5D curved 
track.


Once the first End-Point has been 
selected, the message in the status bar 
changes to read "Select second End-
Point to connect." LEFT-Click on the 
unconnected end of 18" 10D curved 
track.




If the "Connection Distance" is set 
correctly, the track sections move slightly 
and the 18" and 22" curved sections of 
track connect together. 


If they don't, go back to the Preferences 
window and increase the "Connection 
Distance" by 0.05" (1.27 MM). If the 
"Connection Distance" must be 
increased to a value greater than 
0.25" (6.35 MM), re-check the layout to 
ensure the correct sectional track pieces 
have been utilized.


Do a Save now. 

AddSidings 
http://xtrkcad-fork.sourceforge.net/

Wikka/AddSidings


To facilitate the placement of the two 
turnouts (Atlas Snap Switches) required 
to create the siding, it's necessary to 
split the track of the oval layout into two 
sections. 


To make the task of doing so easier, use 
View>Zoom from the Menu Bar or the 
"Change drawing scale" ICON Tool Bar 
button to change the drawing scale to a 
ratio of 4:1. If a mouse has a SCROLL 
function, it can also be used to change 
the Zoom ratio.


If the Map is not open, open it by using 
View>Show/Hide Map or Ctrl+SPACE, 
or the “Map ICON Button”.


To make the first split, drag the 
transparent rectangle in the Map viewing 
area to the lower left quadrant.


Split the track between the bottom left 
22” curve radius piece and the 18” 10D 
curve.


To split the two tracks, select 
Change>Split Track, Shift+Ctrl+S, or 
the “Split a track ICON button”.


With the command active, place the 
cursor over the indicated track joint and 
Left-Click the mouse. 


To show when the track sections have 
split, the single black line, that indicated 
the joint, turns into three lines, the split.


To create the second split, drag the map 
viewing area to the upper right quadrant 
and move the Map window out of the 
way. The split command is still active. 
Place the X of the split between the 9” 
straight and the first 18” curve radius 
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track to its right.  With cursor over that 
joint, LEFT-Click that joint.



The indication when the track split is the 
single black line turned into three lines.

Close the Map window. 

	 	 

Change the drawing scale to a ratio of 
12:1. Once the drawing scale is set, the 
entire layout should be visible in the Main 
Window.


Choose the "Select" Tool.

Change>Select, Ctrl+E or the "Select 
objects" button from the Tool Bar. 


Move the cursor over the top of one of 
the curved sections of track located on 
the right side of the Layout drawing 
window. While holding the cursor over 
this track section, press and hold the 
SHIFT key then LEFT-Click the mouse 
button. Completing this action causes 
the track segment, on the right side and 
across the bottom of the Main Window, 
to be highlighted. 


If the entire track plan highlights when 
the "Select objects" command is issued, 
this indicates one of the previous steps 
wasn't completed correctly.


The Move function is used to relocate the 
highlighted segment of track approx-
imately 9" to the right. 


Select the "Move" tool by using the 
Change>Move function from the Menu 
Bar or Shift+Ctrl+M, the shortcut keys. 

Place the cursor over any piece of track 
located in the highlighted section, press 
and hold the LEFT mouse button. 


Watch the highlighted section of track as 
the mouse is dragged to the right. The 
entire highlighted section of track follows 
the mouse movement. Continue 
dragging the section to the right until 
there's an approximate 9" opening 
between it and the stationary section of 
track to the left. Release the mouse 
button.




Use Edit>Deselect All from the menu 
bar to "Deselect All" layout components 
once editing like this is completed. Doing 
this removes any chance of making 
unintentional changes. 


Make Room for the Right Hand 
Turnout 
To facilitate installation of a right hand 
turnout, it is necessary to remove the 
two sections of the Atlas #821, 9” 
straight track located adjacent to the 
curved track section in the top left 
quadrant of the Main Window.



Pick the "Select" Tool by using the 
Change>Select function from the Menu 
Bar, the "Select objects" button from the 
ICON Bar or the shortcut keys. 


Move the cursor underneath the two 9” 
straight sections to be removed and at 
the left end of the left track section. Hold 
down the LEFT mouse button and drag 
upwards until both tracks are highlighted.  

Release the mouse button.


The two 9” straight tracks, to be 
removed, are highlighted. 


Use the Edit>Delete function from the 
Menu Bar, the shortcut keys or the 
keyboard’s Delete key to delete the 
previously selected 9” straight tracks.


Install the Right Hand Turnout 
LEFT-Click in the Hot Bar to highlight an 
"Atlas #851, Right Snap Switch”, which 
selects it. 


Move the cursor to any open area of the 
drawing window and LEFT-Click. The 
turnout is placed in the drawing area. 


Drag the turnout to the open end of the 
22” curve piece, hold down the LEFT 
mouse button, with the cursor on the 
turnout’s left end, and drag it into 
position.


Ensure the diverging route curves inward 
toward the center of the layout. If it 



doesn’t, hold SHIFT key and Left Click 
the mouse to change the orientation of 
the turnout.


Once the turnout is positioned properly, 
press the SPACE or ENTER key to 
anchor it in position.


Re-connect Straight Track 
Choose the "Select" Tool. 

Change>Select function from the Menu 
Bar, the "Select objects" ICON button 
from the Tool Bar or the shortcut keys. 


Move the cursor over top of one of the 
three sections of straight track located 
along the upper edge of the Main 
window. While holding the cursor over 
this track section, press and hold the 
SHIFT key then LEFT-Click. Completing 
this action causes the three sections of 
straight track to become highlighted. 


If something other then this section of 
track highlights when the "Select 
objects" command is issued, this 
indicates one of the previous steps 
wasn't completed correctly.


While the tracks are still selected, pick 
the "Join" Tool by using the 
Change>Join function from the Menu 
Bar, the "Join two tracks" button from 
the ICON Tool Bar or the shortcut keys. 
Do NOT choose Connect two tracks. 
This is a “Join” command as the tracks 
are far apart.


Move the cursor over top of the left most 
end of the straight track located along 
the upper edge of the Main window. 


While holding the cursor in this 
position, press and hold the SHIFT key 
then LEFT-Click the mouse. Completing 
this action causes a circle to appear at 
the left end of the straight track and the 
phrase "Click on an unselected End-
Point" to appear in the status bar.

Complete the second step of the “Join 
function”. 


Move the cursor over the end-point of 
the right hand turnout and while holding 
the cursor in that position, LEFT-Click 
the mouse button. This action causes the 
straight section of track to move from it's 



previous location and become joined 
with the turnout.


Note: This is not the same as extending 
the tracks to the new turnout. If the 
action puts a longer track in place of the 
original track, the SHIFT-Click action 
might not have been carried out correctly 
to move the tracks. A piece of track was 
added to extend them instead of moving 
the three tracks. 


Press the SPACE or ENTER key too 
anchor the tracks in position.


Extending tracks is also possible and is 
explained further later.


Use the Edit>Deselect All function from 
the Menu Bar or the shortcut keys, to de-
select all previously selected 
components.


Adding a Little Length 
The “room size” of this layout was set at 
48" x 96" (4' x 8'). The layout, as it exists 
presently, has an overall dimension of 
45" x 85.5". If a 2" border is maintained 
between the left edge of the “room/table” 
and the left edge of the layout, then 
there's sufficient room to add at least 
another 6" of running length without 
compromising a similar border on the 
right side of the layout.


LEFT-Click in the Hot Bar to highlight an 
"Atlas #822, 6” Straight”, which selects 
it. 


Move the cursor next to the open end of 
the "Atlas #821, 9” Straight" track and 
Left-Click the mouse. 


Once the track is in position, press the 
SPACE or ENTER key to anchor the 
track in position.


For the second 6” straight, near the 22” 
curve radius piece in the lower left 
quadrant, move the cursor next to the 
"Atlas #836 22" 22.5D Curved" and 
LEFT-Click the mouse.


Once the track is in position, press the 
SPACE bar to anchor the track in 
position.




Reconnect The Right Hand Loop 

Choose the "Select" Tool.

Change>Select function from the Menu 
Bar, the "Select objects" button from the 
Tool Bar or the shortcut keys. 


Move the cursor over the top of one of 
the curved track sections located along 
the right edge of the Main window. While 
holding the cursor over this track section, 
press and hold the SHIFT key then 
LEFT-Click the mouse. Completing this 
action causes the right hand Loop of 
track to become highlighted. 

If something other then this section of 
track highlights, when the "Select 
objects" command is issued, this 
indicates one of the previous steps 
wasn't completed correctly.


First, make sure the Easement Value is 
set to "None". This stops the program 
from adding "easements" to transition 
between straight and curved tracks.


Select the "Move" Tool by using the 
Change>Move function from the Menu 
Bar, the "Move" button from the ICON 
Tool Bar or the shortcut keys. This 
highlights the section to be moved and 
turns the track to be moved to become a 
solid color.


Complete the second step of the Move 
function by dragging the 18” 10D curved 
piece to the"Atlas #822, 6” Straight" 
track and release the mouse button.


Install the Left Hand Turnout 
LEFT-Click in the Hot Bar to highlight an 
"Atlas #850, Left Snap Switch”, which 
selects it. 


Move the cursor to the end of the 18” 
curve track opening between the 18” 
curve track and the "Atlas #822, 6” 
Straight" track. 


LEFT-Click the mouse.


Ensure the diverging route curves inward 
toward the center of the layout. If the 
diverging route curves away from the 
center of the layout, hold the SHIFT key 
and LEFT-Click on the turnout. This 



action causes the next End-Point to 
become active and makes placing the 
turnout easier.


Press the Space or ENTER key to 
anchor the turnout into position.


The Alignment Process 
In order to bring the siding into parallel 
alignment with the mainline, it is 
necessary to place two short pieces of 
18” 10D curved track next to the 
diverging leg of the "Atlas #850, Left 
Snap Switch".


LEFT-Click in the Hot Bar to highlight an 
"Atlas #835, 18” 10D Curved”, which 
selects it. 


Move the cursor to the end of the switch 
in the upper right quadrant.  Left-Click 
the mouse. The 18” 10D curve snaps into 
place.


Press the Space or ENTER key to 
anchor that piece.


Repeat the process for the second piece 
of 18” 10D curved track.


Complete the Siding 
The open end-points within the siding are 
joined using flex track rather than 

sectional track. Flex track is NOT 
selected in the Hot Bar.


Because of the limited space for the 
curve near the “Snap Switch” on the left 
side, easements must be turned off. 
Look at the 'Easement' button on the 
ICON Tool Bar. It should display 
'Easement None'. If this is not the case, 
open the Easement Menu dialog by 
either, clicking the Easement button in 
the Tool Bar, Selecting 
Options>Easements in the Menu Bar 
and select 'None'.


Flex track is added by using the 
Change>Join function from the Menu 
Bar, the "Join two tracks" button from 
the ICON Tool Bar or the command 
Ctrl+J. 


LEFT-Click the end-point of the "Atlas 
#835, 18” 10D Curved" track located on 
the right side of the layout. A dot appear 
once this point is selected.


Move the cursor over the diverging end 
of the "Atlas #851, Right Snap Switch" 


Left-Click and hold the mouse button 
down, AND while holding the left 
mouse button down, slowly move the 
mouse left and/or right to adjust the 



radius of the curve that develops until a 
desired radius is obtained. 


The radius is displayed in the status line, 
which is on the lower edge of Main 
Window. In this example, a given radius 
its set in inches once the left mouse 
button is released. Release the mouse 
button once the desired radius is 
obtained.


In this example, the curve section of flex 
track has a radius of less than the default 
value of 18”. As a result the curve is 
shown in red to warn of the smaller 
radius.


Add a Couple of Spurs 
Two spur lines emanate from the siding 
created in the previous exercise, thus it is 
necessary to add two turnouts (Atlas 
Snap Switches) to the siding. 


To make the task of placing these 
turnouts easier, use View>Zoom from 
the Menu Bar or the "Change drawing 
scale" ICON Tool Bar button to change 
the drawing scale to a ratio of 6:1.


Add Two Right Hand Turnouts 
LEFT-Click on the Hot Bar to highlight 
an "Atlas #851, Right Snap Switch”, 
which selects it.


Move the cursor next to the second 
'Atlas #835, 18" 10D Curved' track that 
was placed in the last exercise. 


Don't worry about disconnecting or 
modifying the underlying flex track, as 
once the turnout is anchored in 
place, XTrkCad performs this task. 


LEFT-Click and then ensure the 
diverging route curves inward toward the 
center of the layout. If the diverging route 
curves away from the center of the 
layout, hold the SHIFT key and LEFT-
Click on the turnout. This action causes 
the next End-Point to become active and 
makes placing the turnout easier.


When the turnout is placed exactly on 
top of the existing track, the message in 
the info bar at the bottom of the window 
will note that two connections have been 
made. 




Once oriented correctly, press the 
Space or ENTER  key to anchor the 
turnout.


Move the cursor to the immediate left of 
the first turnout. LEFT-Click and a 
second turnout is placed. 


Once oriented correctly, press the 
SPACE or ENTER key to anchor the 
turnout in position.


Extend the Diverging Routes 
The diverging routes could be extended 
by drawing two separate pieces of flex 
track on the Main Window, then 
connecting such to the diverging leg of 
each turnout. There is however a simpler 
way. 


Start the process by zooming out of the 
drawing area using View>Zoom from the 
Menu Bar or the "Change drawing scale" 
Tool Bar button to change the drawing 
scale to a ratio of 12:1. 


LEFT-Click on the Hot Bar to highlight 
an “Atlas 150/821 9” Straight”, which 
selects it.


Move the cursor over the end of the 
diverging leg of the turnout that's located 

on the right most side of the siding; the 
first turnout that was placed during this 
exercise.


LEFT-Click and then press the SPACE 
or ENTER key to anchor the 9” straight 
track.


Select Change>Modify from the Menu 
Bar, the "Modify or extend track" ICON 
Tool Bar button or the press the 
<Ctrl+M> keys to issue a "Modify or 
extend track” command.


Position the cursor over the open end of 
the 9” straight track.


HOLD the LEFT mouse button down 
while moving the cursor to the right and 
downward. As the cursor is moved away 
from the 9” straight track the diverging 
leg will extend. 


Continue extending the leg until it 
reaches a length of approximately 15". 
The track length can be viewed in the 
status bar located along the bottom edge 
of the Main Window. Release the 
mouse button once the desired track 
length has been achieved. Seen below.




Next, LEFT-Click on the Hot Bar to 
highlight an “Atlas 150/821 9” Straight”, 
which selects it.



Move cursor over the end of the 
diverging leg of the turnout that's located 
to the left of the turnout that was just 
modified; the second turnout that was 
placed during this exercise.


LEFT-Click and then press the SPACE 
or ENTER key to anchor the 9” straight 
track.


Select Change>Modify from the Menu 
Bar, the "Modify or extend track" Tool 
Bar button or the press the <Ctrl+M> 
keys to issue a "Modify or extend track” 
command.


Position the cursor over the open end of 
the 9” straight track.


HOLD the LEFT mouse button down 
while moving the cursor to the right and 
downward. As the cursor is moved away 
from the 9” straight the diverging leg 
extends. 


Continue extending the leg until it 
reaches a length of approximately 27". 
The track length can be viewed in the 
status bar located along the bottom edge 
of the Main Window. Release the 
mouse button once the desired track 
length has been achieved.


Establish the Specific Spur Lengths 
The "Describe" mode can be used to 
change many of the attributes associated 
with a track element. 


For example; "Describe" mode can be 
used to change the length or position of 
a section of flex track. When using the 
"Describe" mode, one must be aware 
that if a track is connected to other 
tracks, some values (ie. End Point 
positions) cannot be changed.


In this step of the exercise, the 
"Describe" mode is used to set an exact 
length for each spur line. 




Select Change>Properties from the 
Menu Bar, the "Describe objects" Tool 
Bar button or the press the <Ctrl+?> 
keys to select "Describe" mode.


Move the cursor over the section of flex 
track that forms the short spur line and 
then Left-Click the mouse button. 


The Property Sheet for this section of flex 
track opens. 


Position the cursor in the "Length" field 
and then modify the existing entry of 
15.110, in this case,  to read 15.


Watch the section of flex track in Main 
Window as the field is updated. Its length 
is modified shortly after making the 
change. 


Once the correct value has been entered 
in the "Length" field, LEFT-Click on the 
Done button to close the Property 
Sheet.


Next, move the cursor over the section of 
flex track that forms the long spur line 
and LEFT-Click the mouse button. 


The Property Sheet for this section of flex 
track opens. 


Position the cursor in the "Length" field 
then modify the existing entry to read 27. 


Watch the section of flex track in Main 
Window as the field is updated. Its length 
is modified shortly after making the 
change. 


Once the correct value has been entered 
in the "Length" field, click on the "Done" 
button to close the Property Sheet.


Do a Save now. 

Into the Hills 
http://xtrkcad-fork.sourceforge.net/

Wikka/IntoHills


This elevation tutorial does not apply 
directly to the layout in this tutorial, 
therefore nothing was added here.


Running A Train (Noted as Under 
Construction in the Online Tutorial)

http://xtrkcad-fork.sourceforge.net/

Wikka/RunningTrain


A Car Inventory must exist before the 
Run Train feature can be used.  If this 
tutorial was followed from the beginning, 
the “North American Rolling Stock 
Prototype Cars” should already be in the 
Parameters listing.


The following demonstrates how to add 
the Car Inventory, if it doesn’t already 
exist.


http://xtrkcad-fork.sourceforge.net/Wikka/IntoHills
http://xtrkcad-fork.sourceforge.net/Wikka/IntoHills
http://xtrkcad-fork.sourceforge.net/Wikka/RunningTrain
http://xtrkcad-fork.sourceforge.net/Wikka/RunningTrain


Defining a Prototype 
Model Cars (aka "Parts") are based on 
Prototype Cars. 


To add a model car/locomotive, one or 
more Prototypes must be either loaded 
from the Parameter Files or defined from 
scratch.


Loading Prototype Cars from a 
Parameter File if it doesn’t already 
exist. 

From the menu bar open 
File>Parameter Files... 

The Parameter Files window opens.

Select the Library button and then the 
Choose parameters files window opens.


Select the file “North American Rolling 
Stock Prototype Cars” and then LEFT-
Click the Add button.


The Parameters Files window now shows 
the “North American Rolling Stock 
Prototype Cars” added to the list.


Left-Click the Ok button on the 
Parameter Files window.


The Prototype cars are now loaded.


Defining Custom Prototype Cars" can be 
skipped, and was for this tutorial.




Adding An Engine 
Before a train can be run, a Car Part 
must be defined and added to the 
inventory.




Select Manage>Run Trans from the 
main menu, or LEFT-click on the ICON 
that looks like an old steam engine. That 
brings up a warning window that states, 
"There are no cars defined in the current 
Scale. Do you want to use the Car 
Inventory dialog?”


LEFT-Click Yes.


An empty window opens with only a few 
buttons, on the right side of the window, 
highlighted. The upper most highlighted 
button says: Add.


LEFT-Click the Add button.


A new window opens named New HO 
Scale Car.


There are two drop down menus in the 
Prototype line. 


The drop down menu on the left has only 
three choices; Diesel Loco, Freight Car 
and Psngr Car.  


The one on the right opens a list of the 
specific locomotives or cars available for 
the “car” types.


Choose a locomotive from the drop 
down menu. (A GP 35 was chosen.)


With the part number unknown, 12345 
was entered as the Part Number.  A Part 
Number is REQUIRED! If a part number 
is not available, make one up.


While the Description is NOT a required 
field, Diesel Loco GP35 was input.


Once an engine is selected, LEFT-Click 
the Add button.


Note: Nothing appears to happen, but 
the locomotive was added to the Car 
Inventory.




Adding More Cars 
Choose between 4 to 6 cars of any 
length.


Select either Freight Car or Psngr Car.


Continue using LEFT-Clicks and the 
Add button to add more cars. Give each 
one a part number, or just use the same 
part number, as that is a required field. A 
Description can be added if desired.


Once the cars are all selected, LEFT-
Click the Close button when finished.


The Car Inventory window is displayed 
and should look something like this:


LEFT-Click the Close Button. 

The car inventory can be opened at 
anytime using the menu bar 
Manage>Car Inventory.


Placing Cars onto the Layout 

Once the Close button is clicked, the 
chosen “cars” appear in the Hot Bar and 
the Train Control Opens.


To select a car from the Hot Bar, LEFT-
Click on any car to highlight it. 


(Note: This gets tricky 
because, at first, it does 
not seem like it is 
working.)


After highlighting a “car” 
in the Hot Bar, one of 
which one MUST be a 
locomotive to run the 
train, place the cursor 
anywhere over the layout 
area, press and hold the 
LEFT mouse button 
and, while holding 
down the LEFT mouse 
button, start dragging 
to the location where 
the car is to be placed 
on the tracks. The car 

won’t show until the dragging starts. The 
car can be dragged to any track location.


The GP35 was dragged to the long spur 
and it automatically aligned to the track.




The Hot Bar showed five cars left to be 
placed on the tracks with the GP35 
sitting on the innermost spur.


Using the same method, the remaining 
cars, except the caboose, were placed 
on the tracks.


When the caboose was placed on the 
layout, its direction needed to be 
changed.


For clarity, while demonstrating the rotate 
command, the caboose was placed in an 
open area on the layout, rotated, and 
then moved to its track position.

To change the car’s orientation RIGHT-
Click the end of the car and a menu 
opens. 


LEFT-Click Flip in the menu list and the 
car flips orientation.


Once the caboose was flipped it was 
dragged to the end of the far right spur.


The turnouts were changed to the best 
starting position to make up a train, 
based on where the cars were placed.  


To change the turnout points, the SHIFT 
key is held down while the cursor 
hovers over the turnout and a LEFT-
Click is executed.


The coupling/uncoupling points are 
located at either end of the car or 
locomotive.  


The cars couple automatically when 
another car, or the locomotive, is 
extremely close, like “bumped into”.



In order to leave the cars on the spurs, 
the cars have to be uncoupled.


To uncouple cars, hold the Shift button 
down and RIGHT-Click at the end of the 
car that needs to be uncoupled. 




A menu opens and Uncouple can be 
selected from the list. 


LEFT-Click Uncouple and the cars are 
uncoupled and the rest of the train is 
pulled away.


The train was made up and run.




The screen capture was made while the 
train was stopped during its run.


Cars were switched onto spurs and left 
there.


Save File Now. 

Problems and Workarounds 

1. Some of the screen captures of the 
processes in the online tutorial did not 
look like what was happening on a Mac 
screen while the tutorial was being 
followed.




Solution: Accept that the Tutorial uses 
Windows’ screen captures and the Mac 
screen captures are a bit different. 


2. The color blue is mentioned when a 
track element is moved to the layout 
from the Hot Bar. The initial rail lines are 
red on the Mac.  

Solution: Deleted color references and 
noted them as colored lines other than 
black in this tutorial.


3. When the explained process was 
followed exactly in the online tutorial, it 
did not always work, but a workaround 
was found.

Solution: Change the process to one 
that worked.


4. There are too many Icon Buttons in the 
ICON menu bar above the Hot Bar for a 
beginner to start with. It is intimidating 
and confusing.

Solution: Allow only the ICON Buttons, 
useful for the tutorial, to be displayed in 
the ICON menu.  All others were de-
selected in View>Tool Bar. The ICON 
Buttons used for the tutorial were; 
Easement Button, Modify Track Buttons, 
Properties/Select, Train Group Buttons, 
and the Hot Bar.


5. Locating an exact X Y coordinate 
position in the layout drawing area is 
difficult to do with the mouse. 

Solution: Zooming the layout drawing 
area helps some. It also helps to put the 
object in the drawing area for the layout 
and then move the cursor to the exact 
coordinates, a LEFT-Click allows the 
object to move/jump to that exact 
location.


6. Creating a 4’ x 8’ area, as in the online 
tutorial, misses an important point about 
this program.  The manual notes, on 

page 11, “The Options>Layout menu 
specifies the working scale and overall 
room size.”  That is an important 
concept.

Solution: Note it here.


7. Ctrl+Alt+letter commands cause the 
program to crash on a Mac when 
Ctrl+Opt+P is commanded.

Solution: Delete any references to 
Ctrl+Alt+letter short cut combination in 
this version of the tutorial.


8. The terms “Join two tracks” and 
“Connect two tracks” can be confused 
with each other.

Solution: Remember that “Join is for 
tracks that are far apart from each 
other and “Connect” is for when they are 
very close together, but not connected.


9. The Extend the Diverging Routes, 
noted in the online tutorial does not work 
in version 5.2.2GA

What is wrong? and the Solution

When Change>Modify is chosen from 
the Menu Bar, or the "Modify or extend 
track" ICON Tool Bar button”, or the 
<Ctrl+M> keys to issue a "Modify or 
extend track” command is used, it 
appears that the track is extended using 
the radius of the switch.




No matter how the mouse is dragged, 
while holding down the LEFT mouse 
button and dragging, it will NOT create 
a straight track for the spur.

A 9” straight was used in this tutorial to 
connect to the open end of the turnout in 
this tutorial, and then the 
Change>Modify command worked to 
produce a straight siding of flex track.


Any length of Atlas straight track would 
work, but a 9” straight was chosen for 
the tutorial.


This screen capture of the layout shows 
what happens when a 0.75” straight, 
Atlas’ smallest, was joined to the open 
end of the left most turnout and then the 
Modify/Extend command was used to 
add the spur with flex track.


The straight piece is just used to suggest 
to the program to extend the flex track in 
a straight line.

Solution: Change the method for use in 
this tutorial.


10. The Draw Ties, line 6 radio button, is 
set to Solid by default in the 
Options>Display… menu.  

It is not a problem for the tutorial, as the 
layout is small, but it could require a lot 
of computing power for larger layouts 
and take a long time to load a layout.




Once anchored, Solid, the default, looks 
like this:


and is used in the tutorial.


Outline looks like this when anchored:


None looks like this when anchored:


Solution: Note it here.




11. Yahoo Groups no longer exists.  
References to Yahoo groups, in the 
XTrackCAD Wiki, like http://xtrkcad-
fork.sourceforge.net/Wikka/GettingHelp 
are no longer active. The homepage, 
http://xtrkcad-fork.sourceforge.net/
Wikka/HomePage, does have a link to a 
current email/User group link at

https://xtrackcad.groups.io/g/main

Solution: Note it here.


12. Either the SPACE key or the Enter 
key can be used to anchor an object, like 
track, to the layout.  Only the Space key 
was mentioned in the original Beginner’s 
Tutorial on the Wiki site.

http://xtrkcad-fork.sourceforge.net/
Wikka/BeginnerTutorial


13. The “Make Room for Right Hand 
Turnout” in the online tutorial, found in 
the “Add a Siding” section did not work.

Solution: A different method was created 
that does work.


14. Most of the videos on YouTube, 
about using xtrkcad, are either out of 
date or poorly produced and contain out 
of date information. 

The only useful video found, was “A 
Beginners guide to: Using XTrkCAD for 
designing layouts” by user Gosport 
Railworks dated Mar 26, 2021 using 
version 5.1.2a of the program.

https://youtu.be/C7XxCi3Eb68

Unfortunately, the sound level is not too 
good, and, at times, the presenter 
mumbles.

Solution: Watch the video AFTER 
completing this tutorial.


15. How to return to a user’s layout from 
viewing an example layout, found in 
Help>Examples…, is not apparent.


When an example layout is opened, it is 
actively using the program.


If xtrkcad is closed using File>Exit, the 
next time the program is opened, the 
example layout appears.  That is 
because in Options>Preferences the 
On Program Startup radio button, 
located at the bottom of the Preferences 
window is, by default, set to Load Last 
Layout.


To open a user’s 
choice of layout, 
open the File 
menu.  The user’s 
saved layouts 
appear in the 
section just above 
the Exit choice.


The user may 
LEFT-Click any of 
those files to open 
it.


http://xtrkcad-fork.sourceforge.net/Wikka/GettingHelp
http://xtrkcad-fork.sourceforge.net/Wikka/GettingHelp
http://xtrkcad-fork.sourceforge.net/Wikka/HomePage
http://xtrkcad-fork.sourceforge.net/Wikka/HomePage
https://xtrackcad.groups.io/g/main
http://xtrkcad-fork.sourceforge.net/Wikka/BeginnerTutorial
http://xtrkcad-fork.sourceforge.net/Wikka/BeginnerTutorial
https://youtu.be/C7XxCi3Eb68


Solution: Note it here


16. The ICONs in the ICON tool bar may 
be too small to read/see/use 
comfortably.


The ICON size, by default, is set to 16px, 
that is 16 pixels.




The Options>Preferences… selection 
opens the Preferences dialog box.  The 
pixel size, located at the very top of the 
dialog box, can be changed, using a 
radio button, to either 24px or 32px.

Solution: Note it here.


17. Occasionally, when the program is 
opened and the Tip of the Day window 
opens, there is a spurious menu bar 
across the text.


Solution: Close the spurious window.  
The text of the Tip of the Day can then 
be read and then closed.


18. On occasion, a user may choose the 
wrong track section/object from the Hot 
Bar while track planning or the wrong 
car in the Manage>Run Trains Hot Bar. 
How to fix that oops is not noted in the 
online tutorial.

Solution: 
For the wrong track section/object 
selected, press the ESC key and that 
track section/object closes before being 
anchored.


If the wrong car was selected from the 
Run Trains Hot Bar and dragging has 
NOT started, press the ESC key and that 
car closes before being anchored.


If dragging of 
the car was 
started, and 
the wrong car 
has already 
appeared in 
the drawing 
area, Right-
Click on the 
car and a 

menu opens. Select Remove Car from 
the menu.




19. How to print a track plan is not 
mentioned in the online tutorial.

Solution: 

If the current manual has not been 
downloaded, download it from 
TheXTrackCAD Wiki HomePage.

http://xtrkcad-fork.sourceforge.net/
Wikka/HomePage as a reference.


Open the Printer Setup, File>Print 
Setup…


DO NOT ACCEPT THE DEFAULT of 
Any Printer!!! 

IMMEDIATELY change the Format for: 
line, using the drop down menu opened 
with the arrow on the right side of the 
Any Printer line to your printer.


The printer selected for this tutorial is 
shown in the Format for: line.  


LEFT-Click the Apply button to choose 
that printer, as nothing else needs to be 
done on this window. 


If a small printer test is desired, just to 
learn how, open File>Print… and the 
track layout shows a grid superimposed 
on it.  Both the Print window AND the 
layout drawing screen are visible at this 
time.


http://xtrkcad-fork.sourceforge.net/Wikka/HomePage
http://xtrkcad-fork.sourceforge.net/Wikka/HomePage


For a small printer test, set up the Print 
window as shown below.


After the Print window is set up as shown 
in the screen capture, LEFT-Click the 
four squares in the upper, right quadrant 
of the layout screen, as shown in the 
next screen capture.


Note that the Roadbed Outline check 
box was checked and its Width set to 
1.750.  That number is in inches and is 
the width of Midwest HO cork roadbed.  
When the four selected grid sections are 
printed, the cork roadbed lines are are 
also printed.  If the roadbed lines are not 
desired, de-select the Roadbed Outline 
check box.


A LEFT-Click of the Print button does 
NOT send the print job directly to the 
printer.  It opens another window named 
PDF Final Check.  For this tutorial, the 
only change was to select Grayscale, 
which is found in the Color tab. 




If the same Printer setup for this tutorial 
was followed, the four sheets of paper 
can be butt joined and taped together.  


While printing, the program calculates 
the slight “missing” gap correctly and no 
cutting is necessary to join the sheets.


The non-printed gaps are calculated to 
make no difference when the paper is 
butt joined. The center line of the track is 
printed as well as the outlines of the cork 
roadbed.


The current manual has a lot more 
information about printing starting at 
section 2.5.7 Printing.



20. In the parts list, Manage>Parts 
List…, the number of flex track sections 
is NOT noted but, the number 56.744, 
preceding the text HO Flex Track in the 
list, is the number of inches needed.

Solution: Note it here.


Return to the beginning of the tutorial.


